High latency

Incident Report for TrustCloud

Resolved

This incident has been resolved.
Posted Dec 18, 2024 - 14:55 EST

Update

We have released a fix for the root cause of this issue and are currently monitoring the fix.
Posted Dec 18, 2024 - 13:12 EST

Monitoring

We are no longer experiencing elevated latency on the site and are in the process of rolling out a fix to prevent this issue.
Posted Dec 18, 2024 - 12:37 EST

Update

A fix for the issue has been created and is being tested at this time.
Posted Dec 18, 2024 - 12:16 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 18, 2024 - 11:45 EST
This incident affected: TrustCloud, TrustOps, TrustShare, TrustRegister, and Audit Lens.