Platform Outage

Incident Report for TrustCloud

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 23:36 EDT

Monitoring

We’re observing a reduction in error rates and latency across AWS services. Application functionality is gradually returning to normal. Our team continues to monitor the situation closely and will provide further updates if the issue resurfaces.
Posted Oct 20, 2025 - 17:40 EDT

Identified

We are currently facing increased error rates and latencies for multiple AWS services in the US-EAST-1 Region
Posted Oct 20, 2025 - 10:33 EDT

Investigating

We are currently facing increased error rates and latencies for multiple AWS services in the US-EAST-1 Region
Posted Oct 20, 2025 - 10:21 EDT
This incident affected: TrustCloud and TrustOps.