TrustShare Portal Outage
Incident Report for TrustCloud
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 19:17 EDT
Monitoring
The TrustShare Portal was offline from approximately 4:02 AM until 8:10 AM. The issue has been resolved and all TrustShare portals are currently operational. We are continuing to investigate the root cause of the issue.
Posted Jul 18, 2024 - 08:10 EDT
Investigating
The TrustShare portal is experiencing a disruption in service. All TrustShare sites are currently unavailable. We are currently investigating the issue.
Posted Jul 18, 2024 - 04:02 EDT
This incident affected: TrustShare.